use strict;
my $str = 'thedir="C:/oneFolder/subfolder"
thedir="C:/oneFolder/"';
my $regex = qr/^(thedir[ ]*=[ ]*")(.)(:[\/\\])([a-zA-Z0-9]*)([\/\\]?.*)$/mp;
my $subst = '$1Z$3Here$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";