Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?:ISBN(?:-10)?:? )?(?:(?<number>\d{9})|(?=[\dX -]{13}$)(?<registrationGroup>\d{1,5})[ -](?<registrant>\d{1,7})[ -](?<publication>\d{1,6})[ -])(?<checkDigit>[\dX])$
/
gm
Input 1
1
New
359821508X 3598215083X 35982150X 3-598-21508-8 3-598-215087-8 3-598-2150-8 3598-2150-8 359821-5-0-8