$re = '/(?=(?:\b[01]\d|2[0-3])[:∶][0-5]\d\b)/m';
$str = 'Received from SOMEONE 11/02/2020 13∶20 $ 997,63 $ 997,63 -
\'Received from SOMEONE 11/02/2020 13:20 $ 997,63 $ 997,63 -
';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;