re = /homo_seg-/m
str = 'homo_seg-Val-abc-1-1
homo_seg-Beg-cdf-2-1
homo_seg-Try-gfh-3-2
homo_seg-Fuss-cdh-3-1'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result