import Foundation
let pattern = #"homo_seg-"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
homo_seg-Val-abc-1-1
homo_seg-Beg-cdf-2-1
homo_seg-Try-gfh-3-2
homo_seg-Fuss-cdh-3-1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)