import Foundation
let pattern = #"(?<=[^\W0]\w{3,14})\w(?=\w{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0001113033AA55608981 → 0001113*********8981
23456237472347823923 → 2345************3923
00000000090000000000 → 0000000009000***0000
09008000800060050000 → 09008***********0000
AAAABBBBCCCCDDDDEEEE → AAAA************EEEE
0000BBBBCCCCDDDDEEEE → 0000BBBB********EEEE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)