package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z\d-]{1,100}`)
var str = `RE-1234-56-789-0
123-AB-12-INV
123456789
ABCDE
2019-01-19-ABCD
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}