$re = '/^[a-zA-Z\d-]{1,100}/m';
$str = 'RE-1234-56-789-0
123-AB-12-INV
123456789
ABCDE
2019-01-19-ABCD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);