// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z\d-]{1,100}").unwrap();
let string = "RE-1234-56-789-0
123-AB-12-INV
123456789
ABCDE
2019-01-19-ABCD
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}