use strict;
my $str = 'Smith, SMITH, John, JOHN';
my $regex = qr/, *[A-Z]+\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";