import Foundation
let pattern = #"^(feat|fix|perf|refactor|removed)(:\s)(HPA-\d+)(\s)(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
feat: HPA-1234 Test
fix: HPA-1234321 Test
perf: HPA-1234 Тест 123 Test
refactor: HPA-1234 Тест
removed: HPA-1234 Test "тест" 123
ffeat: HPA-1234 Test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)