using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Short";
string input = @"Short 1_29 (to DimmerKueche)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}