import re
regex = re.compile(r"<span style=\"font-size:14px;\">([\w\s]+)(<\/span>)", flags=re.DOTALL)
test_str = ("<div class=\"Description_Productinfo\" itemprop=\"description\"><p><span style=\"color:#7f8c8d;\"><span style=\"font-family:Arial,Helvetica,sans-serif;\"><span style=\"font-size:14px;\">Alphanumeric Words If You Wish To Match</span></span></span></p></div>\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")