#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<\s*style[^>]*>([\s\S]*?)<\s*\/\s*style>"
Local $sString = "<style>" & @CRLF & _
" p {" & @CRLF & _
" color: purple;" & @CRLF & _
" font-family: 'Comic Sans MS';" & @CRLF & _
" font-size: 2em;" & @CRLF & _
" }" & @CRLF & _
"</style>" & @CRLF & _
"" & @CRLF & _
"<p>These styles...</p>" & @CRLF & _
"" & @CRLF & _
"<style lang="scss">" & @CRLF & _
" p {" & @CRLF & _
" color: purple;" & @CRLF & _
" font-family: 'Comic Sans MS';" & @CRLF & _
" font-size: 2em;" & @CRLF & _
" }" & @CRLF & _
"</style>" & @CRLF & _
"" & @CRLF & _
"<p>These styles...</p>" & @CRLF & _
"" & @CRLF & _
"<style>.asd</style>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")