import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*style[^>]*>([\\s\\S]*?)<\\s*\\/\\s*style>";
final String string = "<style>\n"
+ " p {\n"
+ " color: purple;\n"
+ " font-family: 'Comic Sans MS';\n"
+ " font-size: 2em;\n"
+ " }\n"
+ "</style>\n\n"
+ "<p>These styles...</p>\n\n"
+ "<style lang=\"scss\">\n"
+ " p {\n"
+ " color: purple;\n"
+ " font-family: 'Comic Sans MS';\n"
+ " font-size: 2em;\n"
+ " }\n"
+ "</style>\n\n"
+ "<p>These styles...</p>\n\n"
+ "<style>.asd</style>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}