package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^e\s]|[^l]e|[^f]le|[^f]fle|[^a]ffle|[^b]affle)\s*(needle)`)
var str = `baffle needle buffalo
baffle needlebaffle fine
baffle
needle baffleneedle baffle
fine
baffle buffalo
needle buffalo needle
baffle needle
needle baffle fine
needlefine`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}