$re = '/([^e\s]|[^l]e|[^f]le|[^f]fle|[^a]ffle|[^b]affle)\s*(needle)/m';
$str = 'baffle needle buffalo
baffle needlebaffle fine
baffle
needle baffleneedle baffle
fine
baffle buffalo
needle buffalo needle
baffle needle
needle baffle fine
needlefine';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);