// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^e\s]|[^l]e|[^f]le|[^f]fle|[^a]ffle|[^b]affle)\s*(needle)").unwrap();
let string = "baffle needle buffalo
baffle needlebaffle fine
baffle
needle baffleneedle baffle
fine
baffle buffalo
needle buffalo needle
baffle needle
needle baffle fine
needlefine";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}