const regex = /^(\w+)\W+(\w+)\W+(\w+)\h+(##(.+))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+)\\W+(\\w+)\\W+(\\w+)\\h+(##(.+))$', 'gm')
const str = `quirky, stable, fun ##Paul and Jill
mean, rude, sad ##Dave
rich, foolish, gorgeous ##Amanda`;
const subst = `$5|$1$4|$2$4|$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);