re = /^(\w+)\W+(\w+)\W+(\w+)\h+(##(.+))$/m
str = 'quirky, stable, fun ##Paul and Jill
mean, rude, sad ##Dave
rich, foolish, gorgeous ##Amanda'
subst = '$5|$1$4|$2$4|$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result