// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\([A-Z]+\))?FS[A-Z ]*-\d(?:[^\n,()-]*\w)?").unwrap();
let string = "Fakturasadas : (S)FSK-69/23/GFK/12hjkhjkddddd
(S)FSK-69/23/GFK/12S Z (S)FSK-69/23/GFK/ 1 2 .)
FS-1195,1196,1197,2072,2073/24/GF/02, (S)FS-1195/24/GF/02, (S)FS-1196/24/GF/02, (S)FS-1197/24/GF/02, (S)FS-2072/24/GF/02, (S)FS-2073/24/GF/02 (S)FSK-69/23/GF/12
(S)FS-1499/24/GF/01 (S)FS-1500/24/GF/01
I mean if invoice number : FS -444 4/23/F/11 - it also correct to: FS-4444/23/F/11, or FS-4444g/23g/F/1g1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}