$re = '/<h([1-6])>([^<]*)<\/h([1-6])>/mi';
$str = '<h1>Titulo</h1>
bla bla bla
<h3>Outro titulo</h3>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);