// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)<h([1-6])>([^<]*)<\/h([1-6])>").unwrap();
let string = "<h1>Titulo</h1>
bla bla bla
<h3>Outro titulo</h3>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}