#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(84)2(38|7|96|54|09|04|91|16|06|75|15|18|7|9|3|56|5|71|74|90|14|9|13|36|6|61|8|63|51|77|0|69|19|73|97|93|4|6|39|5|8|37|59|34|1|60|1|05|70|35|55|08|03|59|76|10|57|11|07|33|99|94)(\d{7,8})"
Local $sString = "842926263007" & @CRLF & _
"842866598888" & @CRLF & _
"842072214668" & @CRLF & _
"842586504076" & @CRLF & _
"842736588235" & @CRLF & _
"842286544037" & @CRLF & _
"842466577226" & @CRLF & _
"842866739846" & @CRLF & _
"842156516668" & @CRLF & _
"842222210948" & @CRLF & _
"842106286816" & @CRLF & _
"842626338697" & @CRLF & _
"842086567555" & @CRLF & _
"842066562953" & @CRLF & _
"842606502439" & @CRLF & _
"842746294040" & @CRLF & _
"842462538003" & @CRLF & _
"842396542070" & @CRLF & _
"842422456111" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")