#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=npm start)([^=\n]+)(?:=?)(?:['"]+)?([^\n\'\"]+)?(?:[^\S\n]?)"
Local $sString = "npm start search=test" & @CRLF & _
"npm start search=test, bal,sdf" & @CRLF & _
"npm start search=test, bal,sdf " & @CRLF & _
"npm start package-name" & @CRLF & _
"npm start package-name=test-search, 123, sdfasf " & @CRLF & _
"" & @CRLF & _
"npm start search='test'" & @CRLF & _
"npm start search='test, bal,sdf'" & @CRLF & _
"npm start search='test, bal,sdf '" & @CRLF & _
"npm start package-name" & @CRLF & _
"npm start package-name='test-search, 123, sdfasf '" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"npm start search="test"" & @CRLF & _
"npm start search="test, bal,sdf"" & @CRLF & _
"npm start search="test, bal,sdf "" & @CRLF & _
"npm start package-name" & @CRLF & _
"npm start package-name="test-search, 123, sdfasf ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")