import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=npm start)([^=\\n]+)(?:=?)(?:['\"]+)?([^\\n\\'\\\"]+)?(?:[^\\S\\n]?)";
final String string = "npm start search=test\n"
+ "npm start search=test, bal,sdf\n"
+ "npm start search=test, bal,sdf \n"
+ "npm start package-name\n"
+ "npm start package-name=test-search, 123, sdfasf \n\n"
+ "npm start search='test'\n"
+ "npm start search='test, bal,sdf'\n"
+ "npm start search='test, bal,sdf '\n"
+ "npm start package-name\n"
+ "npm start package-name='test-search, 123, sdfasf '\n\n\n"
+ "npm start search=\"test\"\n"
+ "npm start search=\"test, bal,sdf\"\n"
+ "npm start search=\"test, bal,sdf \"\n"
+ "npm start package-name\n"
+ "npm start package-name=\"test-search, 123, sdfasf \"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}