re = /(?<=npm start)([^=\n]+)(?:=?)(?:['"]+)?([^\n\'\"]+)?(?:[^\S\n]?)/m
str = 'npm start search=test
npm start search=test, bal,sdf
npm start search=test, bal,sdf
npm start package-name
npm start package-name=test-search, 123, sdfasf
npm start search=\'test\'
npm start search=\'test, bal,sdf\'
npm start search=\'test, bal,sdf \'
npm start package-name
npm start package-name=\'test-search, 123, sdfasf \'
npm start search="test"
npm start search="test, bal,sdf"
npm start search="test, bal,sdf "
npm start package-name
npm start package-name="test-search, 123, sdfasf "'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end