const regex = new RegExp('(?:\\G(?!\\A)|My\\s+nieces\\s+are)\\s+(\\S+):(\\d+)', 'gm')
const str = `My nieces are Cara:8 Sarah:9 Tara:10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}