$re = '/[a-zA-Z]\<a[^>]+\>.+?\<\/a\>[a-zA-Z]/m';
$str = 'A<a href="asdfadsf">asdfasdf</a>B
B<a href="asdfasdf">sdfsdfsdf</a>C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);