package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((.*?)\)`)
var str = `Голос [сказал](glagol :: edinstvennii :: no_role :: no_group) , что он новый вид [жизни](sushestvitelnoe :: edinstvennii :: no_role :: no_group)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}