# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^CN=.+?(?<!\\),//gm;t' <<< "CN=example,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup
CN=exa\,mple,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup"