$re = '/^CN=.+?(?<!\\\\),/m';
$str = 'CN=example,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup
CN=exa\\,mple,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;