re = /^CN=.+?(?<!\\),/m
str = 'CN=example,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup
CN=exa\\,mple,OU=example,OU=example,OU=example,DC=madeup,DC=madeup,DC=madeup,DC=madeup'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result