#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ":[\d\w]+"
Local $sString = "test2@gmail.com:123456" & @CRLF & _
"test2@hotmail.com:124554134" & @CRLF & _
"test1@yahoo.com:fdsfsdfe" & @CRLF & _
"test5@gmail.com:9875464"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")