package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:[\d\w]+`)
var str = `test2@gmail.com:123456
test2@hotmail.com:124554134
test1@yahoo.com:fdsfsdfe
test5@gmail.com:9875464`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}