re = /:[\d\w]+/
str = 'test2@gmail.com:123456
test2@hotmail.com:124554134
test1@yahoo.com:fdsfsdfe
test5@gmail.com:9875464'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end