#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z]+[0-9/\(\)G]+\s+.+\n"
Local $sString = "E1 0/2/14 down down " & @CRLF & _
"E1 0/2/15 down down " & @CRLF & _
"GE0/0/0 down down " & @CRLF & _
"GE0/3/0(10G) up up Conexao ao Anel AGG RMAGSRM-STRM06-01 GigabitEthernet0/4/0" & @CRLF & _
"GE0/3/1(10G) down down " & @CRLF & _
"GE0/4/0(10G) up up Conexao ao Anel AGG RMCOSRM0101 GigabitEthernet0/3/0" & @CRLF & _
"GE0/4/1(10G) down down " & @CRLF & _
"GE0/7/0 up up Conexao ao Anel ACC RMACSRM-STRM10-01 GigabitEthernet0/3/2" & @CRLF & _
"GE0/7/1 down down " & @CRLF & _
"GE0/7/2 down down " & @CRLF & _
"GE0/7/3 down down " & @CRLF & _
"GE0/7/4 down down " & @CRLF & _
"GE0/7/5 down down " & @CRLF & _
"GE0/7/6 down down " & @CRLF & _
"GE0/7/7 down down " & @CRLF & _
"GE0/8/0 up up Conexao ao Anel ACC RMACSRM-STRM04-01 GigabitEthernet0/3/3" & @CRLF & _
"GE0/8/1 down down " & @CRLF & _
"GE0/8/2 down down " & @CRLF & _
"GE0/8/3 down down " & @CRLF & _
"GE0/8/4 down down " & @CRLF & _
"GE0/8/5 down down " & @CRLF & _
"GE0/8/6 up down " & @CRLF & _
"GE0/8/6.6 up up Conexao ao Servico 3G-<SRMSRMCPL113657>-<PA1808>" & @CRLF & _
"GE0/8/7 down down " & @CRLF & _
"Loop0 up up(s) Loopback Gerencia " & @CRLF & _
"Loop2147483647 up up(s) DCN loopback interface " & @CRLF & _
"NULL0 up up(s) " & @CRLF & _
"S0/2/0:0 up up " & @CRLF & _
"S0/5/0/1:1 down down " & @CRLF & _
"S0/5/0/17:1 down down " & @CRLF & _
"S0/5/0/33:1 down down " & @CRLF & _
"S0/5/0/49:1 down down " & @CRLF & _
"Mg0/RSP0/CPU0/1 admin-down admin-down " & @CRLF & _
"Te0/2/0/0 up up Conexao ao RMCORJO0102 GE5/0/0" & @CRLF & _
"Te0/2/0/1 up up Conexao ao RTOCRJO0101 [Te0/1/0/6]" & @CRLF & _
"Te0/2/0/2 up up Conexao RMCORJO0101 Te0/0/0/2 " & @CRLF & _
"Te0/2/0/3 up up Conexao ao LTE-TIM - PTN -ANEL01" & @CRLF & _
"Te0/2/0/3.2001 up up CONEXAO ^`eNB" & @CRLF & _
"Te0/2/0/3.2002 up up CONEXAO - eNB" & @CRLF & _
"Te0/2/0/3.2003 up up Conexao ao - eNB" & @CRLF & _
"Te0/2/0/3.2004 up up Conexao ao - eNB" & @CRLF & _
"Te0/2/0/3.2005 up up Conexao ao - eNB" & @CRLF & _
"Te0/2/0/3.2006 up up Conexao ao - eNB" & @CRLF & _
"Gi0/3/1/5 up up "Conexao ao RTISRJO0301 [Gig0/0/0] "" & @CRLF & _
"Gi0/3/1/6 up up Conexao ao IPX COMFONE - IPX SERVICES - CPE LOCAL - 120 Mbps" & @CRLF & _
"Gi0/3/1/6.201 up up Conexao ao IPX COMFONE - SIGNALING/DIAMETER - 1 Mbps" & @CRLF & _
"Gi0/3/1/6.202 up up Conexao ao IPX COMFONE - SIGNALING/SS7 - 2 Mbps" & @CRLF & _
"Gi0/3/1/6.203 up up Conexao ao IPX COMFONE - 2/3/4G ROAMING/GRX - 60 Mbps" & @CRLF & _
"Gi0/3/1/7 up up Conexao ao OI - Link LAB TIM/OI - ID OI RJOSL8320483" & @CRLF & _
"Gi0/3/1/7.4000 up up RAN Sharing LTE OI - TIM [1000Mbps]" & @CRLF & _
"Gi0/3/1/8 up up "Conexao ao SMS CLARO"" & @CRLF & _
"Gi0/3/1/8.252 up up PEERING Conexao ao SMS CLARO - Trail RJORJOCPL062543 Accid 57807" & @CRLF & _
"Gi0/3/1/9 admin-down admin-down " & @CRLF & _
"Gi0/3/1/10 admin-down admin-down" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")