import re
regex = re.compile(r"^[a-z]+[0-9/\(\)G]+\s+.+\n", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("E1 0/2/14 down down \n"
"E1 0/2/15 down down \n"
"GE0/0/0 down down \n"
"GE0/3/0(10G) up up Conexao ao Anel AGG RMAGSRM-STRM06-01 GigabitEthernet0/4/0\n"
"GE0/3/1(10G) down down \n"
"GE0/4/0(10G) up up Conexao ao Anel AGG RMCOSRM0101 GigabitEthernet0/3/0\n"
"GE0/4/1(10G) down down \n"
"GE0/7/0 up up Conexao ao Anel ACC RMACSRM-STRM10-01 GigabitEthernet0/3/2\n"
"GE0/7/1 down down \n"
"GE0/7/2 down down \n"
"GE0/7/3 down down \n"
"GE0/7/4 down down \n"
"GE0/7/5 down down \n"
"GE0/7/6 down down \n"
"GE0/7/7 down down \n"
"GE0/8/0 up up Conexao ao Anel ACC RMACSRM-STRM04-01 GigabitEthernet0/3/3\n"
"GE0/8/1 down down \n"
"GE0/8/2 down down \n"
"GE0/8/3 down down \n"
"GE0/8/4 down down \n"
"GE0/8/5 down down \n"
"GE0/8/6 up down \n"
"GE0/8/6.6 up up Conexao ao Servico 3G-<SRMSRMCPL113657>-<PA1808>\n"
"GE0/8/7 down down \n"
"Loop0 up up(s) Loopback Gerencia \n"
"Loop2147483647 up up(s) DCN loopback interface \n"
"NULL0 up up(s) \n"
"S0/2/0:0 up up \n"
"S0/5/0/1:1 down down \n"
"S0/5/0/17:1 down down \n"
"S0/5/0/33:1 down down \n"
"S0/5/0/49:1 down down \n"
"Mg0/RSP0/CPU0/1 admin-down admin-down \n"
"Te0/2/0/0 up up Conexao ao RMCORJO0102 GE5/0/0\n"
"Te0/2/0/1 up up Conexao ao RTOCRJO0101 [Te0/1/0/6]\n"
"Te0/2/0/2 up up Conexao RMCORJO0101 Te0/0/0/2 \n"
"Te0/2/0/3 up up Conexao ao LTE-TIM - PTN -ANEL01\n"
"Te0/2/0/3.2001 up up CONEXAO ^`eNB\n"
"Te0/2/0/3.2002 up up CONEXAO - eNB\n"
"Te0/2/0/3.2003 up up Conexao ao - eNB\n"
"Te0/2/0/3.2004 up up Conexao ao - eNB\n"
"Te0/2/0/3.2005 up up Conexao ao - eNB\n"
"Te0/2/0/3.2006 up up Conexao ao - eNB\n"
"Gi0/3/1/5 up up \"Conexao ao RTISRJO0301 [Gig0/0/0] \"\n"
"Gi0/3/1/6 up up Conexao ao IPX COMFONE - IPX SERVICES - CPE LOCAL - 120 Mbps\n"
"Gi0/3/1/6.201 up up Conexao ao IPX COMFONE - SIGNALING/DIAMETER - 1 Mbps\n"
"Gi0/3/1/6.202 up up Conexao ao IPX COMFONE - SIGNALING/SS7 - 2 Mbps\n"
"Gi0/3/1/6.203 up up Conexao ao IPX COMFONE - 2/3/4G ROAMING/GRX - 60 Mbps\n"
"Gi0/3/1/7 up up Conexao ao OI - Link LAB TIM/OI - ID OI RJOSL8320483\n"
"Gi0/3/1/7.4000 up up RAN Sharing LTE OI - TIM [1000Mbps]\n"
"Gi0/3/1/8 up up \"Conexao ao SMS CLARO\"\n"
"Gi0/3/1/8.252 up up PEERING Conexao ao SMS CLARO - Trail RJORJOCPL062543 Accid 57807\n"
"Gi0/3/1/9 admin-down admin-down \n"
"Gi0/3/1/10 admin-down admin-down\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")