2the literal 2 (5010 / 628 / 3216)
\d{3}a digit, repeated exactly 3 times
-the literal - (4510 / 558 / 2D16)
0the literal 0 (4810 / 608 / 3016)
1-9one character from 1 (4910) to 9 (5710)
1the literal 1 (4910 / 618 / 3116)
0-2one character from 0 (4810) to 2 (5010)
-the literal - (4510 / 558 / 2D16)
Group 2(0[1-9]|[1,2][0-9]|3[0,1]) 0the literal 0 (4810 / 608 / 3016)
1-9one character from 1 (4910) to 9 (5710)
2nd Alternative[1,2][0-9] 1the literal 1 (4910 / 618 / 3116)
,the literal , (4410 / 548 / 2C16)
2the literal 2 (5010 / 628 / 3216)
0-9one character from 0 (4810) to 9 (5710)
3the literal 3 (5110 / 638 / 3316)
0the literal 0 (4810 / 608 / 3016)
,the literal , (4410 / 548 / 2C16)
1the literal 1 (4910 / 618 / 3116)
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string