#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)Modifications\s*((?!Modifications\s*).)*"
Local $sString = "99645," & @CRLF & _
"\Submitted'," & @CRLF & _
" '\Modifications made 2015/01/01'," & @CRLF & _
" 'change0: --> info0'," & @CRLF & _
" 'change1: --> info1'," & @CRLF & _
" 'change2: --> info2'," & @CRLF & _
" 'change3: --> info3'," & @CRLF & _
" '\Modifications made 2015/01/03'," & @CRLF & _
" '\Modifications made 2015/01/05'," & @CRLF & _
" '\Modifications made 2015/01/07'," & @CRLF & _
" 'change0: --> info0'," & @CRLF & _
" 'change1: --> info1'," & @CRLF & _
" '\Modifications made 2015/01/07',"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")