$re = '/(?sm)Modifications\s*((?!Modifications\s*).)*/';
$str = '99645,
\\Submitted\',
\'\\Modifications made 2015/01/01\',
\'change0: --> info0\',
\'change1: --> info1\',
\'change2: --> info2\',
\'change3: --> info3\',
\'\\Modifications made 2015/01/03\',
\'\\Modifications made 2015/01/05\',
\'\\Modifications made 2015/01/07\',
\'change0: --> info0\',
\'change1: --> info1\',
\'\\Modifications made 2015/01/07\',';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);