$re = '/^(?=\D*\d)[a-zA-Z0-9]{1,5}$/';
$str = 'AV5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);