using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Z|\u0400-\u042F])(?=.*[a-z|\u0430-\u044f])(?=.*[\d])(?=.*[!@#$%^&*.])[\u0400-\u04FF\d\w!@#$%^&*.]{8,70}$";
string input = @"2АРОЛЬПАРОЛЬ2.єфіііііїїїїыыъw";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}