const regex = /^(?=.*[A-Z|\u0400-\u042F])(?=.*[a-z|\u0430-\u044f])(?=.*[\d])(?=.*[!@#$%^&*.])[\u0400-\u04FF\d\w!@#$%^&*.]{8,70}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[A-Z|\\u0400-\\u042F])(?=.*[a-z|\\u0430-\\u044f])(?=.*[\\d])(?=.*[!@#$%^&*.])[\\u0400-\\u04FF\\d\\w!@#$%^&*.]{8,70}$', 'g')
const str = `2АРОЛЬПАРОЛЬ2.єфіііііїїїїыыъw`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}