package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,2}\s\w{3,5}\s\d{2,4}`)
var str = `26 March 21 , 19 Feb 2021,12 Feb 21,19 March 21`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}