using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((https?|ftp):\/\/[\w?!=&.\/-;#@~%+*-]+(?![\w\s?!&.\/;#~%""=-]>))|((magnet):[\w?=&.\/-;#@~%+*-]+))";
string substitution = @"<a href=""$1"" rel=""nofollow"">$1</a>";
string input = @"<?php
```
<?php
```
https://test.de
### headline
</code>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}