import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((https?|ftp):\\/\\/[\\w?!=&.\\/-;#@~%+*-]+(?![\\w\\s?!&.\\/;#~%\"=-]>))|((magnet):[\\w?=&.\\/-;#@~%+*-]+))";
final String string = "<?php\n\n"
+ "```\n"
+ "<?php\n"
+ "```\n\n"
+ "https://test.de\n\n"
+ "### headline\n\n"
+ "</code>";
final String subst = "<a href=\"$1\" rel=\"nofollow\">$1</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}