package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z]\w+\'?\w*`)
var str = `Random01'example`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}