package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[01]?[0-9]{1,2}(?:\.[0-9]+)?$`)
var str = `0.0
50.123
150.103
199.99
200
200.00
200.01
205.111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}