re = /^[01]?[0-9]{1,2}(?:\.[0-9]+)?$/m
str = '0.0
50.123
150.103
199.99
200
200.00
200.01
205.111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end